Srcpuppet

下载puppet

首先从 puppet download page 下载稳定版的facter和puppet软件包.

安装依赖的包

puppet是用 ruby语言开发的,因为puppet的安装依赖一些ruby的库,下面是需要安装的ruby库

  • base64
  • cgi
  • digest/md5
  • etc
  • fileutils
  • ipaddr
  • openssl
  • strscan
  • syslog
  • uri
  • webrick
  • webrick/https
  • xmlrpc

安装facter

facter是一个安装puppet的必要软件,解包并安装

tar zxf facter-1.5.7.tar.gz
cd facter-1.5.7
ruby install.rb

安装 puppet

tar zxf puppet-0.25.4.tar.gz
cd puppet-0.25.4
ruby install.rb
除非特别注明,本页内容采用以下授权方式: Creative Commons Attribution-ShareAlike 3.0 License